Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Can't get tx to bind with rx

Joined
Oct 28, 2018
Messages
5
Reaction score
8
Age
20
Hi! I'm totally new to this hobby! I've been flying quite a lot with DJI, Hubsan and Parrot drones, but all of these are bought RTF. And I thought that i should try to build my own racing quad and try some fpv flying. And i'm surprised that I've even made it this far in the building process. (I've been using a beginners guide!) I'm using the following things in my build:

Frame: Martian II Anniversary Edition 215 mm
FC: Omnibus F4 A10 OSD
Motor: Dragonfly Hurricane 2207 2500kv
ESC: Racerstar RS30A V2
RX: FrSky XSR
FPV Cam: Foxeer XAT600M HS1177
VTX: Eachine VTX03
(+ Buzzer and Low ESC Capasitor)

Transmitter: Taranis QX7

Now, as far as I know I've managed to solder everything to the right spot on the quad, and as all the parts was connected, I wanted to bind the RX and TX to test and see if the motors would respond correctly and to setup failsafe.
BUT, here comes the problem. I can't manage to complete binding procedure, and I don't know what I'm doing wrong... I do as all the YT videos say I should, and in the videos it works, but not for me (as usual :).

Is there anyone who could help me figure out what the problem might be!? Is there a setup that has to be made on the transmitter, have I soldered the wrong wires from the RX, do I have to plug it all into a software program etc.???
I really want to get this thing working!

Thanks in Advance!!
 
Joined
Oct 28, 2018
Messages
5
Reaction score
8
Age
20
Are you sure you are not bound?
Once bound you will need to set up switches on your tx and in betaflight or whatever you are running , arm, angle, horizon, acro.
Can you send a video of your process?

Oh by the way, welcome to the addiction.
Wayne
Thanks for the reply! What I do here is that I press binding for internal rx (the settings for my rx are correct). And it starts beeping, indicating its ready. So I long press the rx fs button as I plug in the battery, and as it stops beeping, it should be a solid green light. But mine is solid red and green. Some say that is due to not having the same firmware (eu/international) on the rx and tx, they need to have the same according to a video on YT. But how I change that is also a big problem for me. I am also unfamiliar with the setup of switches in beta flight and tx that you mention...
Thanks again!
P.S I did film my binding process but the website wont let me upload it... But is exactly like this one, exept for the error in the end for my part.
 
Last edited:

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
1,599
Reaction score
1,650
Location
The Chesapeake Bay
You already know your problem, just not how to fix it, you have mismatched firmwares. When you get a new Frsky RX you will want to flash it with the latest US or EU before you ever install it. There is no real way to tell what rev is on it but of course if it won't bind (solid red) then you at least know it is the wrong type of firmware. See if this helps you get through it.

 

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
1,599
Reaction score
1,650
Location
The Chesapeake Bay
Also you will want to make sure your QX7 is updated to OpenTX 2.2.2, and maybe 2.2.3 is out now, haven't looked so I'm not sure if it is out yet but get the latest. If your TX came in with 2.2.2 then you are fine for now. When you go to flash the RX some things have changed since this video, if you have 3 pins in the bottom of your TX to the left of your SD card then you will use those instead of the pins in the JR module bay and you will use "Flash S.Port" instead of "Flash Ext. Module". Let us know if you run into any issues and we can try to help.
 
Joined
Oct 28, 2018
Messages
5
Reaction score
8
Age
20
This is really awesome help and tips!! Now i've got the firmware to a micro sd card which is in the transmitter ready to be used. But do i recycle a cable to connect with the rx and in that case, how do I know which pin is 5v/gnd/tel? The taranis manual says that it's smart port connection, and an original S. port plug is needed.... Or can I use the pins in the ext. rx hub anyway? Thanks again!
 

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
1,599
Reaction score
1,650
Location
The Chesapeake Bay
I read through Oscars document, it is a bit much for someone new, but the info is there.
If you have any questions or concerns before you go to do this, please let us know.
I can make a video and post it here to help you if needed. But to directly answer your questions from above...

The pin closest to the SD card slot is the pin that goes to the S.Port on the RX

If you can find one simply use a "servo cable" to plug into the bottom of the TX, I will post a picture of mine in the next comment.

Yes you will need to recycle the cable unless you have an extra (I ordered a few off Banggood so I would never have to de-solder my cable)

So in short, the pin closest to the SD card slot on the TX will go to the S.Port pin on the RX and I will post a picture of my cable I made next for example.
 
  • Like
Reactions: CompleteNoobRacer

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
1,599
Reaction score
1,650
Location
The Chesapeake Bay
I think something may not be correct there, and you do NOT need another cable, it can be easily done with what you have without desoldering. I am busy at the moment, if you can give me till later this evening to look this over and do some checking, I will give you a rundown of how to do with what you currently have.
 
  • Like
Reactions: CompleteNoobRacer
Joined
Oct 28, 2018
Messages
5
Reaction score
8
Age
20
I think something may not be correct there, and you do NOT need another cable, it can be easily done with what you have without desoldering. I am busy at the moment, if you can give me till later this evening to look this over and do some checking, I will give you a rundown of how to do with what you currently have.
Thanks a lot! And hey, no hurry! Theres no need for rushing this!
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
2,757
Messages
24,236
Members
2,339
Latest member
9TFoX