Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

USB Connection Killing Sounds

Torc

Well-Known Member
Joined
Mar 24, 2018
Messages
147
Reaction score
114
Age
46
Location
Cincinnati
Website
www.youtube.com
I have noticed that twice my sounds have gotten pooched after playing on the PC version of FreeRider. At first, I thought it was because I disconnected while the TX was still powered up but after fixing the sounds and making sure to turn off the TX each time before disconnecting, my sounds are not functioning again.

Anyone had this issue before, and if so, how did you correct the issue permanently?
 

theGreenOrange

Well-Known Member
Joined
Oct 18, 2016
Messages
2,457
Reaction score
1,739
Location
New Orleans, LA, USA
It sounds like a driver problem. When it happens, you can try to disable your sound card in device manager then re-enable it.

Not sure if you can prevent it other than being sure your motherboard drivers are all up to date, especially the chipset drivers and sound drivers.
 

theGreenOrange

Well-Known Member
Joined
Oct 18, 2016
Messages
2,457
Reaction score
1,739
Location
New Orleans, LA, USA
Oh, does anything related to the controller show up in the safely remove hardware area in system tray at the lower right when it is plugged in?
 

Torc

Well-Known Member
Joined
Mar 24, 2018
Messages
147
Reaction score
114
Age
46
Location
Cincinnati
Website
www.youtube.com
Making sure we are not the same page. The sounds in my TX are effected, not on the PC.

It sounds like a driver problem. When it happens, you can try to disable your sound card in device manager then re-enable it.

Not sure if you can prevent it other than being sure your motherboard drivers are all up to date, especially the chipset drivers and sound drivers.
 

Torc

Well-Known Member
Joined
Mar 24, 2018
Messages
147
Reaction score
114
Age
46
Location
Cincinnati
Website
www.youtube.com
Oh, does anything related to the controller show up in the safely remove hardware area in system tray at the lower right when it is plugged in?
I had not looked but it might not be a bad idea to do that before turning the TX off.
 

Latest threads

Members online

Forum statistics

Threads
2,694
Messages
23,588
Members
2,276
Latest member
Alike