Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Not getting enough lift?

spiderpig

Well-Known Member
Joined
Feb 13, 2017
Messages
167
Reaction score
58
Age
45
So I did a test flight of my 180 quad today since I got the FC installed. I took it for a spin indoor to see what kind of power its got. I found that I was almost at full throttle before it would lift. So I"m not sure if its me, some configuration, the motors, or the props.

So here's the specs on it:
Props:
Amazon.com: Hobby-Ace 24PCS Gemfan 4045 Bull Nose Props ABS Propeller CCW CW for QAV250 Multirotor Quadcopter (Black Green and Orange): Toys & Games
Motors and ESC:
Amazon.com: HOBBYMATE Quadcopter Kit Motor ESC Combo, 2 Pairs CW CCW 2204 2300KV Plus 4 PCS Upgrade BLHeli 15A ESC for For 180 210 250 RC Quadcopter Drone Multirotor: Toys & Games
Battery:
Amazon.com: Floureon 2 Packs 3S 11.1V 2200mAh 25C RC Rechargeable Lipo Battery XT60 Plug for DJI Phantom FC40 Spare Walkera E22RC Quadcopter Drone and FPV (4.17x1.38x0.91 Inch): Toys & Games
FC:
Amazon.com: RJX SP Racing F3 EVO Cleanflight Flight Controller for Racing Drone Quadcopter: Toys & Games

I flashed the FC to latest Cleanflight build. I changed the radio modes to arm with on aux channel and with other aux channel I can switch between angle, horizon, and acro mode. I tested to make sure all motor were spinning in the right direction on Cleanflight. Also calibrated the accelerometer.

Did I miss configuring something that it's barely getting lift at almost max throttle? This is my first build so I'm new to Cleanflight in general.


Here's the video of the first indoor flight...I could get it to hover ok...but took almost full throttle go up. I was in angle mode.

So any advice? I'm glad I got something flying at least...this Friday I'm hoping to clean up the wiring so it doesn't look too much like a mess.
 

theGreenOrange

Well-Known Member
Joined
Oct 18, 2016
Messages
2,456
Reaction score
1,749
Location
New Orleans, LA, USA
Does your max throttle on the configuration page match up with what the receivers tab shows for your radio's max throttle value? Are the lipos fully charged?
 

spiderpig

Well-Known Member
Joined
Feb 13, 2017
Messages
167
Reaction score
58
Age
45
Lipo waas charged before hand and when I checked it after that flight it showed at 11.3v. I just did a quick check this morning of my setting in clean flight. My radio throttle goes from 1071 to 1990. On the configuration page it shows min throttle at 1150, max throttle at 1850, and min command at 1000. So does that mean that after my throttle go too 1850 it ignored the rest of the inputs? What would you guys suggest I set my min, max and min command to? Will try to test more tonight after work.

UPDATE: So doing a bit to research it seems like I need to do at least two things:
1) Calibrate my ESC since they've never been connect3ed to the FC before. Was looking at how to do that on CleanFlight. Would that be good enough, or should I research BLHeli method?
2) Change my min throttle to 1080 and max throttle to 1990, with minimum command at 1050.

Does that make sense?
 
Last edited:

spiderpig

Well-Known Member
Joined
Feb 13, 2017
Messages
167
Reaction score
58
Age
45
Calibrated the ESC and modified the throttle setting like I said in last post. Did a test and she seems better. I was hovering at around 50-60 percent.


So I did notice that if I turn on one shot (which my ESC are suppose to support) the motors do a little twitcing thing. I turned it off for now, but is there a special way to activate it? Is it better then not having it?
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
3,455
Messages
29,637
Members
2,926
Latest member
frier15