Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Lost Video

rtkDarling

Well-Known Member
Joined
Nov 1, 2018
Messages
711
Reaction score
1,073
Age
37
I lost camera video on my 3" rig. No crash, I've never even flown it more than a few seconds to test it. VTX is still projecting, but there's no startup graphics from the FC and all I'm getting is a black screen. Changed the camera, it works, changed the wires to the camera, they seem fine. I'm at a loss, any suggestions?
 
  • Wow
Reactions: HighTechPauper

rtkDarling

Well-Known Member
Joined
Nov 1, 2018
Messages
711
Reaction score
1,073
Age
37
I had this issue on a omnibus f4 had to replace it to get OSD.
but it still works fine with the camera connected to the vtx.
I had this happen to my very first FC which was a DYS F3. Back then I had no idea what I was doing. I connected the camera straight to the VTX, and destroyed the quad on the 2nd pack. I've set up a timer on my controller, but I'm afraid I'm going to roast lipos without a voltage warning.
 
  • Sad
Reactions: HighTechPauper

Sambo1988

Well-Known Member
Joined
Dec 29, 2017
Messages
130
Reaction score
58
Age
31
What camera are you running? The most cameras now have the facilities to run a voltage meter that will show your battery voltage in your goggles without the need for fc osd
 
  • Like
Reactions: HighTechPauper

rtkDarling

Well-Known Member
Joined
Nov 1, 2018
Messages
711
Reaction score
1,073
Age
37
What camera are you running? The most cameras now have the facilities to run a voltage meter that will show your battery voltage in your goggles without the need for fc osd
I forgot about that... It's a Micro Eagle, so it should. I've never used a camera setup remote, I'll mess around with it.

Thanks!
 
  • Like
Reactions: HighTechPauper

Sambo1988

Well-Known Member
Joined
Dec 29, 2017
Messages
130
Reaction score
58
Age
31
It’s easy to do mate there is plenty of Vids on YouTube I have to do it regular my 3inch still has an f3 in it and no osd. Just run the cable to the positive battery pad.
 
  • Like
Reactions: HighTechPauper

Wrecked

Well-Known Member
Joined
Feb 21, 2019
Messages
84
Reaction score
114
Location
Denmark
Happend on my US65 tinywhoop too. Im just using a timer on my transmitter set to 2 min.
 
  • Like
Reactions: HighTechPauper

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
2,368
Reaction score
2,756
Location
The Chesapeake Bay
Yup, the OSD circuit on the FC failed, there has been a real rash of those things failing lately, don't know if it is poor quality solder or oven reflow, board traces failing, or the chips themselves, but every time I turn around someone is having their camera feed fail to make it into the OSD feed.
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
3,283
Messages
28,543
Members
2,805
Latest member
Kafpv