Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

I have an issue with my Taranis X9D throttle.

ebeez

Well-Known Member
Joined
Jun 16, 2018
Messages
462
Reaction score
785
Age
51
If you watch the video below you will see that the throttle response is very slow. I created a new model on the transmitter and the issue is the same. I can't tell if it is a gimbal issue or one of the boards is dying? Has anyone ever encountered this at all? Any suggestions are welcome and always appreciated.

 

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
2,484
Reaction score
2,892
Location
The Chesapeake Bay
I had a very similar issue recently, when I upgraded the OpenTX to I think 2.3.8 I ran into terrible slowness and downright delay in all of my stick movements. At first I thought it was a quad, but them a second quad acted like that and I knew it was the controller. I pulled the back off and removed and reseated the 4 gimbal plugs on the board, removed the RTC battery for a minute and updated to 2.3.9 and the issue was gone. Not sure which it was but I believe it was the 2.3.8 OpenTX.
 
  • Like
Reactions: ebeez

ebeez

Well-Known Member
Joined
Jun 16, 2018
Messages
462
Reaction score
785
Age
51
Hey HighTechPauper! Thanks for the quick response. I'll have a look at that. It's my friends TX so I will see what level Open TX is at. Thank you for the suggestion!! Will let you know what I find.
 
  • Like
Reactions: HighTechPauper

ebeez

Well-Known Member
Joined
Jun 16, 2018
Messages
462
Reaction score
785
Age
51
I had a very similar issue recently, when I upgraded the OpenTX to I think 2.3.8 I ran into terrible slowness and downright delay in all of my stick movements. At first I thought it was a quad, but them a second quad acted like that and I knew it was the controller. I pulled the back off and removed and reseated the 4 gimbal plugs on the board, removed the RTC battery for a minute and updated to 2.3.9 and the issue was gone. Not sure which it was but I believe it was the 2.3.8 OpenTX.
Interesting. the F/W and Opentx was at the latest level. I opened up the transmitter and reseated the wires from the gimal. Also re-soldered the antenna as it was a little shaky. Re-flashed and all is good now .. I dunno... will see how it goes.
 
  • Like
Reactions: HighTechPauper

ebeez

Well-Known Member
Joined
Jun 16, 2018
Messages
462
Reaction score
785
Age
51
Hey HighTechPauper! Thanks for the quick response. I'll have a look at that. It's my friends TX so I will see what level Open TX is at. Thank you for the suggestion!! Will let you know what I find.
oops I forgot to thank you for the suggestion. Appreciate your input!
 
  • Like
Reactions: HighTechPauper

Latest threads

Members online

Forum statistics

Threads
3,343
Messages
28,922
Members
2,852
Latest member
E4zl