Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

How to get my AIO working?

Squiggle

Well-Known Member
Joined
Feb 16, 2018
Messages
92
Likes
28
Age
44
#1
Hey guys, I just upgraded my FC from a Racerstar F3S to an F4S & I cant get any response from the radio. I’m using a Spektrum 4649T & I read somewhere that F4 controllers have a problem with the uninverted signal that Spektrum requires. I've had a look for solder pads to do this but there is nothing labeled, I have found two pads on the board that could be the ones but they aren’t labeled. Could the ones circled in the pic be the ones I need to bridge?

P.S. does anyone else think it’s weird that all F4 boards invert the signal only for it to be uninverted after sale? F3 boards don’t have this problem, why would the newer version? (End of rant, lol)

8E9F420B-C389-4086-B4E5-198A8116DE01.jpeg
 

RENOV8R

Well-Known Member
Joined
Jan 29, 2018
Messages
269
Likes
304
Age
58
#2
I don't think those pads will work, they actually look like they might be for bridging between 3.3v/5v. I would try connecting to the rx for the GPS UART, I'm guessing it's uninverted. Worth a try and you can't hurt anything if I'm wrong.
 

Squiggle

Well-Known Member
Joined
Feb 16, 2018
Messages
92
Likes
28
Age
44
#3
Awesome dude, I soldered the signal wire to the rx & enabled UART6 & it worked!! Thank you so much. Now why can’t they put that in the instruction/pinout diagram? It’s like they completely forgot about Spektrum, lol.
 

Latest threads

Members online

Forum statistics

Threads
2,062
Messages
19,368
Members
1,755
Latest member
Emilplf