Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Got a new one for you guys...JJPro T1

Jtrjr

Well-Known Member
Joined
Mar 9, 2016
Messages
1,528
Reaction score
1,220
Location
Texas
Website
www.youtube.com
So I saw a video today by MicroRCFiend where he flashed Betaflight on his T1 and it flew great. So I figured I'd do the same. I began the flash and it looked like it completed but after it was done I could no longer connect with BetaFlight. Like the FC got bricked.

I spent the entire day trying to correct the problem to no avail. I keep getting the no response from boot loader message. I researched everything I could find and it appears that the board in mine is different from any other one I've been able to find. Of course, there is no information out there about my board at all.

The board has a built in FrSky TX and has a bind button but has no boot pins or pads. I've tried every combination of using the bind button that I can come up with. I just can't get this thing in boot loader mode. I've checked all of my STM32/CP210x drivers and Zadig and all us good.

Does anyone recognize this board or have any suggestions?


Here's a link to the T1 I purchased:

Amazon.com: Usmile JJPRO-T1 95mm Micro Carbon Fiber BNF Quadcopter Features Brushed F3 with built-in Frsky-Compatible Receiver 25mw 40CH AIO Camera VTX Combo for Micro Indoor fpv racing Support FrskyTaranis X9D: Toys & Games

Thanks in advance for any advice.

Jerry
 

Jtrjr

Well-Known Member
Joined
Mar 9, 2016
Messages
1,528
Reaction score
1,220
Location
Texas
Website
www.youtube.com
Damn!!!! I think you're right!!! Man, you have no idea how much time I've spent looking at that damned board! That's why I figured I'd post the pics and see if someone else could see something. I'm going to check it out, I'll let you know. Thanks so much!

Jerry
 

Jtrjr

Well-Known Member
Joined
Mar 9, 2016
Messages
1,528
Reaction score
1,220
Location
Texas
Website
www.youtube.com
Green,

You were correct, those are the boot pins. I was able successfully flash several different Betaflight and Cleanflight versions. The process goes correctly, the flash starts, verifies and shows "programming successful" each time. I disconnect, remove the short, reboot Cleanflight/Betaflight (I've even tried rebooting the computer. When I go into CF/BF it shows in the upper left corner that it has opened the serial port, when I hit connect it changes to communicating but after a few seconds it times out with failed to communicate.

All of the info I've been using is on the other board (the Scisky) which has the target as a NAZE controller. I can't find any info on the board I have, I have to wonder if maybe it's not a NAZE? Not sure where to go from here.

Jerry
 

Jtrjr

Well-Known Member
Joined
Mar 9, 2016
Messages
1,528
Reaction score
1,220
Location
Texas
Website
www.youtube.com
FLASHED!!! It's an SPR F3 not a NAZE!

Thanks for all of your help. If you hadn't found those boot pins I would have given up!

Jerry
 
  • Like
Reactions: theGreenOrange

Jtrjr

Well-Known Member
Joined
Mar 9, 2016
Messages
1,528
Reaction score
1,220
Location
Texas
Website
www.youtube.com
Green,

The T1 is back in the air with the latest version of BF! Can't take it outside or in the house (dogs don't like it) just yet but down in the basement it feels as good as it ever has. I'm just in Horizon but it damn near sits a a dead hover. I can't wait to get it out to give it a real test!

I wouldn't have got it done without your help and being able to bounce stuff off of you. Thanks again!

Jerry

 
  • Like
Reactions: theGreenOrange

Latest threads

Members online

No members online now.

Forum statistics

Threads
3,455
Messages
29,629
Members
2,926
Latest member
frier15