Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Found no valid ESC configuration - BlHeli_32 Error

Xx69420xX

New Member
Joined
May 30, 2020
Messages
3
Reaction score
1
Age
21
I'm running a HGLRC FD765 F7 FC & 65A BL_Heli 4in1 3-6s ESC Stack. It is explicitly stated to be running BlHeli_32 firmware in the product description. Everything works fine in Betaflight, but I'm looking to reverse 2 of my motors and have a rickroll as my startup tone. I can connect to BlHeli_32 suite 1.0.0.3 on MacOS, and I can spin up individual motors in BlHeli_32 fine as well. The "Write Setup" button is greyed out and when I hit "Check" to check the ESC's I get the error in the title.

I'm especially confused as I can spin up the motors in BlHeli_32, but not actually do anything useful like reading my setup or even flashing my ESC's without this exact error message (as in the title). Any advice?

I have attached a screenshot of the main BlHeli_32 screen, as I see it.

Edit: Here is an imgur link to a 1min video showing the problem.
 

Attachments

Last edited:

Xx69420xX

New Member
Joined
May 30, 2020
Messages
3
Reaction score
1
Age
21
I've fixed the problem with BlHeli_32. The issue was that my FC was running 4.1.0 firmware, which I believe should have worked with BlHeli_32 but I updated that to 4.1.7 in betaflight and it's now working well. Perhaps this can help someone who has the same problem as me.
 
  • Like
Reactions: HighTechPauper

Latest threads

Members online

Forum statistics

Threads
3,292
Messages
28,588
Members
2,815
Latest member
Insanetec