Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

FC wont connect to PC or operate properly...

baevans11

Well-Known Member
Joined
Aug 3, 2017
Messages
206
Reaction score
93
Age
37
I have a Lumenier micro lux v3 f4 stack that I just did a rebuild with. Before the rebuild everything worked fine with all the same components. I did update the escs with blheli32. I was trying to fix a video issue caused by vtx and rx being too close or touching. Once I realized the issue was fix and was about to unplug the lipo & put everything back together again the esc made some random beeps and then went crazy spinning the motors. Now when I try to connect the fc to betaflight I only get a red light on fc and no sound from PC. None of the other components light up when I plug in to pc but they do if I plug in lipo. Also the esc makes all kinds of beeps and chimes for a lengthened amount of time then the motors spin up randomly. This all seemed to start after updating the 4 in 1 esc. I was just flying these components on a different frame with no issues. I'd appreciate any help or advice on how to diagnose/fix this setup. Thanks in advance for any help!
 
  • Wow
Reactions: HighTechPauper

baevans11

Well-Known Member
Joined
Aug 3, 2017
Messages
206
Reaction score
93
Age
37
Does passthrough functionality still work? Meaning can you still access BLheli config?
I'm not sure but I'll check. I wouldn't think so since I cant connect to betaflight or blheli32. It doesnt even recognize anything is plugged in. I know I have all the right drivers on my laptop as well cause it worked fine before the update you know.
 
  • Like
Reactions: HighTechPauper

baevans11

Well-Known Member
Joined
Aug 3, 2017
Messages
206
Reaction score
93
Age
37
Does passthrough functionality still work? Meaning can you still access BLheli config?
I checked last night and it isnt recognized by anything. All I get is a red light. I will say this I did have a driver issue when trying to connect to blheli32 to do the update. I had to use zadig to get it connected even though it would connect to betaflight before that. What's weird is it would connect to betaflight after that too but once it spazed out it wont connect to anything. Im stumped lol. I guess I will have to use zadig again to see if somehow the driver got messed up somehow. Thoughts? Thanks!
 
  • Like
Reactions: HighTechPauper

rtkDarling

Well-Known Member
Joined
Nov 1, 2018
Messages
519
Reaction score
658
Age
37
Sorry, I'm stumped too. I would likely start with the FC and try to get that back up. Sometimes there's a bootloader that needs to be bridged, or sometimes it's a button you can press on startup that will let you reflash the FC. Good call on the drivers though, because if NOTHING is coming up then it could be a problem on the computer side.

As I'm writing this I realized that I would try my OTG cable. It's a special USB that allows me to connect my FC to my phone and make changes there. If it connects to the phone you can sure it's a driver issue.
 

baevans11

Well-Known Member
Joined
Aug 3, 2017
Messages
206
Reaction score
93
Age
37
Sorry, I'm stumped too. I would likely start with the FC and try to get that back up. Sometimes there's a bootloader that needs to be bridged, or sometimes it's a button you can press on startup that will let you reflash the FC. Good call on the drivers though, because if NOTHING is coming up then it could be a problem on the computer side.

As I'm writing this I realized that I would try my OTG cable. It's a special USB that allows me to connect my FC to my phone and make changes there. If it connects to the phone you can sure it's a driver issue.
Oh man that's an awesome idea! I didnt think of that. Thanks!
 

baevans11

Well-Known Member
Joined
Aug 3, 2017
Messages
206
Reaction score
93
Age
37
Sorry, I'm stumped too. I would likely start with the FC and try to get that back up. Sometimes there's a bootloader that needs to be bridged, or sometimes it's a button you can press on startup that will let you reflash the FC. Good call on the drivers though, because if NOTHING is coming up then it could be a problem on the computer side.

As I'm writing this I realized that I would try my OTG cable. It's a special USB that allows me to connect my FC to my phone and make changes there. If it connects to the phone you can sure it's a driver issue.
Well I tried your idea and it was a no go even though my other quads connected to speedy bee just fine so its obviously a problem with the board. I did find something interesting when I tried to solder the boot pins and connect to my pc to try and flash. I did get the chimes from the pc saying something was connecting but even with running immersionrc driver fixer it would connect. I'm at a loss too be sure lol. I'll try and reach out to board company to see if they have any ideas. Thx again.
 

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
1,679
Reaction score
1,763
Location
The Chesapeake Bay
My guess is that you loaded BLHeli32 onto a BLHeli_S ESC and due to that the ESC's corrupted the BF on your FC (just like an FC, the ESC's will do screwy things with the wrong firmware loaded), and that may have left you with a dead but undamaged FC.

With the boot pins shorted you will not be able to "connect" to the FC, it is in DFU mode and that is a raw mode meant for flashing the FC memory. Try going into BF configurator and flashing the FC with the correct version for your board, if it flashes desolder the boot pins and then double check what kind of ESC's you have on that quad and reflash the appropriate firmware on them.
 
  • Like
Reactions: baevans11

baevans11

Well-Known Member
Joined
Aug 3, 2017
Messages
206
Reaction score
93
Age
37
Hey thanks for your reply! This is the stack I have and it is a 4 in 1 blheli32 esc. I do agree something went wrong with the flash.


I did try and put the fc into dfu mode and reflash it but I cant get it to actually go into dfu mode. I tried using immersionrc driver fixer and still no luck. I also tried using zadig and when clicking list all devices it doesnt even show up in the list of connected devices in that either. I'm at a loss of what to try at this point. Thanks for your input!
 
  • Like
Reactions: HighTechPauper

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
1,679
Reaction score
1,763
Location
The Chesapeake Bay
Hey thanks for your reply! This is the stack I have and it is a 4 in 1 blheli32 esc. I do agree something went wrong with the flash.


I did try and put the fc into dfu mode and reflash it but I cant get it to actually go into dfu mode. I tried using immersionrc driver fixer and still no luck. I also tried using zadig and when clicking list all devices it doesnt even show up in the list of connected devices in that either. I'm at a loss of what to try at this point. Thanks for your input!
If you want a hand, shoot me a PM and we will figure out a time to have a look.
Randy
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
2,826
Messages
24,731
Members
2,384
Latest member
ZeroPoint