Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Eachine x220 / SP Racing F3 / Betaflight 3.3.2 Buzzer issues

Joined
May 24, 2018
Messages
16
Likes
4
Age
34
Location
Melbourne, Australia
#1
Hi All - Hoping someone may be able to assist?

I'm fairly green when it comes to drones so excuse the terminology ;)

So I've recently installed a 5v Matek Lost model beeper to my x220, and followed a pretty straight forward guide - connecting power source to VBAT and then connecting buzzer to the points marked on the board as per below images
upload_2018-5-25_18-4-43.png upload_2018-5-25_18-5-21.png

All seemed pretty straight forward and to some extent works fine... Now my problem.

When i fire up my drone i hear the power on beeps (from the new buzzer), arming beeps, failsafe beeps and probably more but for some reason when i flick my lost drone switch on AUX3 i can see that LED blinking faster but no beeps, i also don't hear any beeps for lost connection when i turn off my controller.

I've turned betaflight upside down trying to find something that looked odd, but have exhausted everything i know and everything i have read to no avail.

My switches are setup correctly and work fine, Ive disabled and re-enabled all beeper settings through CLI commands and the config, and also restored all settings to default with no resolve..

Its driving me nuts and i'm sure its something i'm overlooking - but now i'm lost.

Any help would be much appreciated!
 
Joined
May 24, 2018
Messages
16
Likes
4
Age
34
Location
Melbourne, Australia
#3
beeper GYRO_CALIBRATED
beeper RX_LOST
beeper RX_LOST_LANDING
beeper DISARMING
beeper ARMING
beeper ARMING_GPS_FIX
beeper BAT_CRIT_LOW
beeper BAT_LOW
beeper GPS_STATUS
beeper RX_SET
beeper ACC_CALIBRATION
beeper ACC_CALIBRATION_FAIL
beeper READY_BEEP
beeper MULTI_BEEPS
beeper DISARM_REPEAT
beeper ARMED
beeper SYSTEM_INIT
beeper ON_USB
beeper BLACKBOX_ERASE
beeper CRASH FLIP
beeper CAM_CONNECTION_OPEN
beeper CAM_CONNECTION_CLOSED

Thank you! and let me know if you need anything else
 

M3talrocksFPV

Well-Known Member
Joined
Feb 22, 2018
Messages
247
Likes
136
Age
27
Location
Las Vegas
Website
www.youtube.com
#8
No luck with that either - all of the other beeps still functioned correctly, but still no beeps on lost drone switch.
I'm thinking mode isn't set up right? Then again mine doesn't work on my wizard either and but all others do, if I find a solution I'll post it, for now i'm using dshot for my beeps
 
Joined
May 24, 2018
Messages
16
Likes
4
Age
34
Location
Melbourne, Australia
#17
This is why i'm so puzzled - everything to my knowledge is setup correctly... and i did stumbled across that forum with the USB plugged in but i have that setting on.

I did connect lipo to vbat at the same time as it was part of a tutorial i followed - would this have anything to do with it?

Georgi Yanev | How to add a buzzer to the Eachine Wizard x220

and i also had to replace the VTX, but that operates fine and i don't see why that would cause any issues..

Would a full CLI dump offer any further insight?
 

NeoCloneOne

Well-Known Member
Joined
Oct 6, 2017
Messages
141
Likes
109
Age
51
#19
It may be working but needs a timeout to test. Try this power on transmitter and receiver (drone). Make sure you confirm you are getting communication by arming/ disarming motors (like you are going to fly/ end-of-flight). Then just power off the radio transmitter (leave drone on). Wait 5 minutes. The lost drone beeps should beep out of the buzzer. If it does, it's working fine.
 
Joined
May 24, 2018
Messages
16
Likes
4
Age
34
Location
Melbourne, Australia
#20
So the problem has been solved!....

Credit to Voodoo614 on RC Groups - The Matek buzzer has to be wired differently to others - Matek 5V Buzzer

Before rewiring the buzzer i did manage to get the lost signal beep working by switching to ibus over ppm, but this still didn't give me the lost drone beep

Everything now beeps as it should - Happy Days!!! :)

Thanks to everyone for the help! Much appreciated.
 
Likes: Wayno52

Latest threads

Members online

No members online now.

Forum statistics

Threads
1,945
Messages
18,447
Members
1,650
Latest member
Abhiman