Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Drone so unstable it cant take off

Joined
Apr 15, 2018
Messages
6
Likes
3
Age
20
#1
So i just got done rebuilding my drone. replaced my 4 in 1 esc with individual DSHOT 1200 escs. they are makerfire blheli_32 escs. i also just upgraded to the most recent betaflight with dshot commands. my flight controller is a sp racing f3. Earlier today i was trying to fly and it would just flip out every time i gave it throttle. turns out my board orientation was set incorrectly so i fixed that. it is now set up properly but every time i take of it is so unstable that i cannot stay in the air. I normally fly in acro mode but even in angle mode i cant get it off the ground. please help.

update: so i just found a little more information that might help. when i spin up the motors in beta flight some interesting stuff happens. when i use the master to spin up all four motors motor 4 doesnt spin up until about half throttle. when i spin up ONLY motor number 4 it works just fine. if i spin up motor number 4 and leave it at low throttle then spin up another motor them motor 4 stops completely. almost like the other motors are sucking power from motor 4.

update 2: i was just playing around in the betaflight motors tab. i noticed that when i use the master throttle slider and i turn it up and then turn it all the way down to zero the motor beeps as if i was arming the quad. every single time i give it throttle and then cut it off it beeps like i was arming it
 
Last edited:
Joined
Apr 15, 2018
Messages
6
Likes
3
Age
20
#3
Do they work in multishot? If you havent tried muktishot and calibrated the ESCs, try that (for troubleshooting).
well to be honest it was late and i was frustrated so i hadnt even though of changing my esc protocol. i just tried dshot 600 and everything worked just fine so i didnt see the need to even go back to multishot and try it out. Although i have no issues running dshot600 i am still curious as to why 1200 wont work. here is a cli dump with dshot 1200 enabled if that helps
 
Likes: Futuramille
Joined
Apr 15, 2018
Messages
6
Likes
3
Age
20
#7
Dshot won't work on pin 4 at all? Even though everything seems to run smoothly on dshot600 are there issues that I am just not noticing.
 

theGreenOrange

Well-Known Member
Joined
Oct 18, 2016
Messages
2,457
Likes
1,739
Location
New Orleans, LA, USA
#8
I'm not 100% sure but I had an emax fc where one motor pin didn't have a timer so that pin could not do DMA. I had to remap it to the LED pin to get it working. But mine would not work on dshot600 so I dont know why yours works with 600 since both 600 and 1200 need DMA to work. Did you fly it with 600?
 
Joined
Apr 15, 2018
Messages
6
Likes
3
Age
20
#9
I'm not 100% sure but I had an emax fc where one motor pin didn't have a timer so that pin could not do DMA. I had to remap it to the LED pin to get it working. But mine would not work on dshot600 so I dont know why yours works with 600 since both 600 and 1200 need DMA to work. Did you fly it with 600?
Haven't flown it yet, just haven't had the time. But I did a couple full throttle punches with no props on and everything seems to be working fine.
 

Latest threads

Members online

Forum statistics

Threads
2,156
Messages
20,028
Members
1,828
Latest member
Deyvid