Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Can a Flight Controller damage an esc?

baradrian

New Member
Joined
Dec 29, 2019
Messages
2
Reaction score
0
Age
35
Hello, i have just started a new build for a few days back, after i connected the esc and the fc, everything was ok the motors spinning and the telemetry got in the fc. But after a short time i could not see the motors in betaflight and and the esc made no more startup noise, the current is passing trough the esc to the fc but the esc is not responding anymore and i think is fried. My question is, can a fc to destroy the esc ?
Esc Tmotor 4 in 1 f45A 4 to 6 s , 32 bit. Fc Lumenier Lux F7
Thank you very much.
 

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
2,487
Reaction score
2,892
Location
The Chesapeake Bay
If there are no 3 tone ESC startup tones it does sound like the ESC may be dead somehow, but I have never heard of how an FC could do the damage. When the battery is plugged in and the ESC gets power, you would normally get 3 tones, then if the FC has power and the motor signal wires show the correct info to the ESC, then the ESC will make 2 additional tones to say that the FC has checked in and the ESC sees it properly. If you have a meter check for a short between positive and negative battery connections as well as any soldering. Also check that your battery has sufficient charge, this happened to me once when the battery had dropped and I got some lights and such, but no tones or function, later I checked the battery voltage and realized it was way too low.
 

baradrian

New Member
Joined
Dec 29, 2019
Messages
2
Reaction score
0
Age
35
I have tried with new battery, i have tried everything is no tone from the esc, the strange part is that at the beginning the esc did not start all at one after the first tone, the 2 additional tones were not synchronized, after i update the esc i got 3 bad packets reading on 3 esc, but after a reboot everything was ok and the motors were spinning properly, i got the same situation with another 4 lumenier razor esc, and i´m wondering if not the fc can be faulty, causing all the esc to burn .... i have cheeked the solder connection end everything seems ok
 

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
2,487
Reaction score
2,892
Location
The Chesapeake Bay
I have 3 or 4 quads that start with staggered/un-synced ESC startup tones, but they fly fine. There is no consensus on what causes this, but I have never seen a post saying that it was a problem or that it caused any issue.
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
3,352
Messages
28,965
Members
2,876
Latest member
stoem