Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Bumblebee FC Problem

Jelli794

New Member
Joined
Jul 26, 2020
Messages
4
Reaction score
4
Age
34
I am new to FPV but not to drones. Got a iFlight Bumblebee and had the bright idea to flash the latest firmware to it. I think I might have flashed an incorrect firmware or something, but now all I get is a solid tone from the beeper, and a red light. It started that as soon as I began flashing and won't stop even when I unplug and plug it back in. I also can't get my mac or beta flight to see the drone now. Did I burn our the board, or do I need to refresh or something? Any help would be awesome. FC for the drone is SucceX-A F405 40A AIO Board
 
  • Like
Reactions: HighTechPauper

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
2,548
Reaction score
2,968
Location
The Chesapeake Bay
It sounds like you flashed the wrong BF target onto the board, find the boot button on the FC, hold it while plugging in USB, and try to see if you can re-flash it. You may need to go download and install an older Configurator version if it won't flash an older rev correctly, I saw this on 10.6 and 10.7 trying to flash back to 3.5.7, installed 10.4 Configurator and all went well after that.
 
  • Like
Reactions: Jelli794

Jelli794

New Member
Joined
Jul 26, 2020
Messages
4
Reaction score
4
Age
34
What’s the proper firmware (or target name)
for that board? I was struggling to make sure I had the right one selected.
 
  • Like
Reactions: HighTechPauper

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
2,548
Reaction score
2,968
Location
The Chesapeake Bay
It's a new board with FC and ESC's all in one, according to iFlight it should be IFLIGHT_F405_AIO, and the oldest FW for that board is rev 4.1.0
I hate the new stuff with specialty designs like this, they can be finicky and when you blow and ESC you have to trash the whole thing. Not the best design or economic situation to be in.
 
  • Like
Reactions: Jelli794

Jelli794

New Member
Joined
Jul 26, 2020
Messages
4
Reaction score
4
Age
34
It’s working after reflashing the correct firmware. Lost all the bumblebee v2 default settings though... :(
 
  • Like
Reactions: HighTechPauper

Latest threads

Members online

No members online now.

Forum statistics

Threads
3,436
Messages
29,526
Members
2,917
Latest member
Shylz