Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

Building my first 250 quad, some teething probs

Paulthebrilliant

New Member
Joined
Apr 5, 2017
Messages
2
Reaction score
2
Age
54
Hi all,

I was wondering if anyone could give me some advice.

I have built my first quad, its a 250 quad with naze32 rev6 emaxrs2205 motors, 5045 props, littlebee oneshot 30a esc's, flyskyi6s, flysky fsia6b 1500ma 75c batterys.

The problem i am having is that although i can hover and manoeuvre the quad slowly if i put too much throttle on the quad it just stops and drops out of the sky, i have to manipulate the controls very very gently to prevent the motors cutting out, i have been using only angle mode so far.
I have configured the naze32 using cleanflight, i have synced the escs but most of the cleanflight settings are default including all the PID settings.

When the quad drops out of the sky i cant seem to restart the motors as it drops, but the esc's dont reset or bleep and the naze still responds to the bleerper so its not like the processor is resetting.

I read it may be a voltage drop causing the esc's to cut out but i dont think it is, if i stand on the quad i can rev it right up without it cutting out at all or the low battery voltage going off. my soldering is good and the battery's are fully charged,


Can anyone help? i have attached a copy of my naze config.
 

Attachments

Latest threads

Members online

Forum statistics

Threads
3,455
Messages
29,629
Members
2,926
Latest member
frier15