Welcome to DroneRacingPilots!
Join our free drone racing community today!
Sign up

4in1 ESC not beeping at all, but powering up flight controller and another parts

aqwamhm

New Member
Joined
May 20, 2020
Messages
3
Reaction score
0
Age
19
Hi everyone, newbie user here. So this is my first 5inch build, let me tell the story.

last week I tried to build my 5-inch quad with ESC Mamba 506 and FC T-Motor f4, but, I connected the wrong cable when connecting ESC to FC, so my T-MOtor F4 was fried. Then I replaced my T-Motor F4 with Mamba F405 (this tme, I'am using TBS Smoke Stopper), and this is the problem I got:

When I plug the battery into the ESC, my ESC doesn't make any beeping sound (looks like it's not getting power). But, FC and other parts (VTX, Camera, Receiver, etc.) turnend on and working properly. When I tried to start the motor with Betaflight, none of the motors started. in BLHELI_32, when I click "read setup", it displays "Found no valid ESC configuration" error.

Trouble Shooting I have done:
- Looking for a short circuit in ESC with Multimeter, but found none
- Unplug FC from ESC, but ESC still does not sound and work

My question is: if my ESC is broken why does it keep on turning on FC and other parts? For wiring, I have checked many times and 99% sure there are no errors

Please help and thank you for the answer

- Aqwam
 

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
2,234
Reaction score
2,611
Location
The Chesapeake Bay
Hi @aqwamhm, welcome to the forum!
There are many parts on the ESC, the 5v regulator is a separate circuit from the actual ESC part, it sounds like the ESC has been blown or was bad from the beginning. Even if the FC is not attached the ESC should make the first 3 tones at power up. It is kind of like a car, the motor may run but if the transmission is bad the car won't move. a picture of your soldering job on the battery pigtail to the ESC might help.
 
  • Like
Reactions: brettbrandon

aqwamhm

New Member
Joined
May 20, 2020
Messages
3
Reaction score
0
Age
19
Hi @aqwamhm, welcome to the forum!
There are many parts on the ESC, the 5v regulator is a separate circuit from the actual ESC part, it sounds like the ESC has been blown or was bad from the beginning. Even if the FC is not attached the ESC should make the first 3 tones at power up. It is kind of like a car, the motor may run but if the transmission is bad the car won't move. a picture of your soldering job on the battery pigtail to the ESC might help.
just noticed something new, my ESC gets hot in a few seconds when the battery is connected, is it normal? . Very hot but still touchable. Btw does the Esc Battery connection cause this problem? If my Esc Battery connection is not good, FC and other parts should not turn on
 

HighTechPauper

Well-Known Member
Joined
Feb 5, 2017
Messages
2,234
Reaction score
2,611
Location
The Chesapeake Bay
The ESC should NOT get hot, so this is not normal, what is wrong I do not know. The battery pigtail connection could be an issue, think of it like this, you have a water supply, it is enough to fill a garden hose, but not enough to fill 4 fire hoses, so the garden hose works ok but the fire hoses do not. But I doubt this is the case and I fear the ESC may be bad. The ESC has a CPU also that must run the BLHeli program to make the ESC work, if it is not then the "computer" part of the ESC will be dead.
 
  • Like
Reactions: brettbrandon

aqwamhm

New Member
Joined
May 20, 2020
Messages
3
Reaction score
0
Age
19
The ESC should NOT get hot, so this is not normal, what is wrong I do not know. The battery pigtail connection could be an issue, think of it like this, you have a water supply, it is enough to fill a garden hose, but not enough to fill 4 fire hoses, so the garden hose works ok but the fire hoses do not. But I doubt this is the case and I fear the ESC may be bad. The ESC has a CPU also that must run the BLHeli program to make the ESC work, if it is not then the "computer" part of the ESC will be dead.
Okay, I think my ESC is dead. But, what is the cause? I have never heard the beep sound from ESC. Could it be that I got a defective product or because of my mistake when frying FC before? Thanks for your help, really appriacte
 

Latest threads

Members online

Forum statistics

Threads
3,214
Messages
27,941
Members
2,755
Latest member
-Rick-